Inicio > 32 bits en 64 bits, consola/terminal, Instalación, Ubuntu Gutsy > Skype en Ubuntu Gutsy Gibbon 7.10 para 64 bits

Skype en Ubuntu Gutsy Gibbon 7.10 para 64 bits

Si sois usuarios habituales de Skype en Windows ya sabréis que existe una versión para Linux, y que viene conveniente empaquetado para distintas distribuciones, incluida Ubuntu. También seréis conscientes de que, por el momento, no se pueden hacer videoconferencias con él.

Sin embargo, también conoceréis que no existe una versión compilada para 64 bits, sino que sólo está disponible en los 32 bits.

En este post os explico cómo he hecho para que este cliente de mensajería instantánea funcione en mi Ubuntu de 64 bits.

skype-32-icono.png

Resumen

Para los que no quieren leerse el “cómo lo hice” que viene a continuación (que también incluye métodos que no me han funcionado), aquí va un resumen para la resolución rápida de la instalación de skype en Ubuntu 64 bits:

1. Descargar el paquete skype para Ubuntu Feisty desde la página del desarrollador.
2. Instalar los paquetes libqt4-core y libqt4-gui, con sudo apt-get install libqt4-core libqt4-gui
3. Forzar la instalación del paquete skype*.deb con sudo dpkg -i –force-architecture skype*deb
4. Descargar el script GetLibs para resolver las dependencias de 32 bits.
5. Ejecutar sudo getlibs /usr/bin/skype en consola.

Descargar Skype

Si intentamos Habilitar el repositorio oficial y descargarlo con Synaptic tenemos que tener en cuenta que, de momento, no funciona para Ubuntu 64.

En esta dirección tenéis una descripción de qué agregar a nuestros repositorios:

skype-repositorio-oficial.png

Yo lo hago a través de Synaptic.

De esa página copiamos la línea deb http://download.skype.com/linux/repos/debian/ stable non-free y la mantenemos en el portapapeles.

Abrimos Synaptic y vamos al menú Configuración > Repositorios, pestaña Software de otros proveedores. Damos al botón Abrir y pegamos la línea anterior:

skype-anadir-repositorio.png

Tras dar al botón Cerrar y pulsar Recargar, comprobaremos que existe un error: el repositorio, literalmente, no existe:

skype-no-existe-el-repositorio.png

Así que, lo que funciona perfectamente para Ubuntu Gutsy Gibbon 7.10 de 32 bits no lo hace para nuestra versión de 64 bits… hay que buscar otro camino…

El Paso a Paso

paso uno Descargar el paquete de Skype desde el sitio del desarrollador

En la dirección de descargas de Skype podremos encontrar diversas posibilidades. Aunque no existe un enlace para una versión específica para Gutsy, escogemos la de Feisty (la que he recuadrado en rojo):

skype-enlaces-de-descarga.png

Si estáis usando Firefox, en breves instantes aparecerá el típico cuadro de Abrir con… o Guardar en…:

skype-descarga-con-abrir-con-gdebi.png

 

Si, inadvertidamente, damos al botón Aceptar, cuando termine de descargarse el programa se iniciará automáticamente el instalador gdebi de paquetes. Como estamos intentando instalar una versión para 32 bits, nos advertirá de ello:

skype-gdebi-arquitectura-incorrecta.png

… y no continuará la instalación.

¿Dónde está el paquete de skype?, ¿hay que volver a bajarlo? No, no es necesario, valga esto como truquito si es que no lo encontramos en el Escritorio: vamos al gestor de descargas de Firefox (menú Herramientas > Descargas) y hacemos clic con el botón derecho del ratón sobre la línea del paquete de Skype:

skype-donde-se-ha-descargado.png

Se abrirá una ventana del administrador de archivos (nautilus) en el lugar donde se ha descargado el paquete. Conviene recordar dónde está para los siguientes pasos o mejor, moverlo al Escritorio para tenerlo más a mano.

paso dos Forzar la instalación de Skype

Como en el caso de otros programas de 32 bits, es necesario que el sistema contenga una serie de bibliotecas que puedan asegurar tanto la instalación como el funcionamiento de los mismos dentro de nuestro entorno de 64 bits. Este tipo de dependencias son algo “especiales” y quizás necesitemos de ayuda extra.

notaSin embargo, si ya habéis instalado otro software de 32 bits en vuestro Ubuntu de 64 (por ejemplo, el plugin de Adobe Flash) ya hay parte del trabajo hecho, ya que con sus dependencias también se han instalado parte de esas bibliotecas, pero para este post intento partir de cero y así intentar cubrir todos los frentes.

Para comprobar qué nos va a faltar tenemos que tirar de consola. Así que la abrimos desde el menú Aplicaciones > Accesorios > Terminal.

Nos movemos a la carpeta en la que está el paquete deb de Skype que hemos descargado desde la página de Skype. Si está en nuestra carpeta personal no es necesario dar este paso, pero si está en el Escritorio, escribimos:

cd Desktop

…y pulsamos la tecla [Intro]

A continuación escribimos:

sudo dpkg -i --force-architecture skype*deb

… y pulsamos [Intro]

Tecleamos la contraseña de nuestro usuario y pulsamos [Intro]. El programa dpkg tratará de instalar el paquete, para lo que hará un análisis del mismo. La salida el programa nos indica que no ha podido porque le faltan algunas dependencias:

skype-32-salida-de-consola.png

En resumen, nos está diciendo que necesita los paquetes libqt4-core y libqt4-gui para seguir el proceso de instalación. Una opción la mar de válida sería usar Synaptic (buscamos esos paquetes y los marcamos para instalar), pero ya que estamos en la consola seguiremos en ella.

paso tres Escribimos lo siguiente:

sudo apt-get install libqt4-core libqt4-gui

… y pulsamos la tecla [Intro].

Comenzará la descarga e instalación de estos paquetes en breve. Cuando nos devuelva el control de la consola, escribimos de nuevo (o pulsamos la tecla [arriba] hasta que la veamos aparecer):

sudo dpkg -i --force-architecture skype*deb

… y observamos lo que ocurre:

skype-consola-aparentemente-instalado.png

Aparentemente está instalado. Probamos a ejecutarlo escribiendo ahí mismo:

skype

… y pulsamos [Intro].

Efectivamente, skype no se ejecuta, sigue pidiéndonos algo más: en este caso se trata de la biblioteca libQtDBus.so.4. Si tratamos de descargarla con apt-get (o synaptic) no la vamos a encontrar: sencillamente, la versión que está buscando Skype es de 32 bits, y la que tendremos referenciada en nuestro sistema de paquetes va a ser la de 64.

paso cuatro Es aquí cuando vamos a echar mano de la ayuda extra de la que hablaba: el script GetLibs, desarrollado por Cappy, un habitual de Ubuntuforums. No está en los repositorios que tenemos configurados, así que podemos descargarlo pulsando en este enlace. Esta vez no habrá problemas al instalar, ya que Gdebi procederá a su instalación sin indicar error alguno:

skype-instalacion-de-getlibs.png

Bastará con dar al botón Instalar el paquete y en pocos instantes lo tendremos disponible.

paso cinco GetLibs es un programa para la consola, así que volveremos a ella y escribimos:

sudo getlibs /usr/bin/skype

El programa comprobará qué está necesitando skype para funcionar, y nos propondrá descargar las bibliotecas que nos son necesarias:

skype-getlibs-en-accion.png

Escribimos S (“s” mayúscula) y pulsamos [Intro]. En poco tiempo se descargarán e instalarán las dependencias que faltaban.

Hacemos una prueba: ejecutamos skype desde la consola:

skype

… y en unos instantes tenemos lo siguiente:

skype-funcionando.png

Hale, a chatear… y a hablar; por las pruebas que he hecho funciona correctamente el audio. El vídeo, de momento, sigue sin ser desarrollado para linux. Tampoco existe la posiblidad, por el momento, de traducirlo al español.

A partir de ahora podremos acceder a skype desde el menú Aplicaciones > Internet > Skype.

Referencias

Risolvere le dipendenze, en Divilinux Lost Blog.

getlibs: Automatically solves dependencies for binaries, en UbuntuForums.

Anuncios
  1. Daspor
    octubre 21, 2007 en 2:12 pm

    Buenas, debo decir que este articulo es el mejor sobre el tema que he visto.
    Es uno de los pocos que se pueden entender.

    Esta super bien estructurado.

    Te has ganado un seguidor del blog xD

    Ya he instalado skype y flash…. en amd64 😛
    Solo falta zattoo que supongo que con el mismo procedimiento del skype funcionara!

    Bueno, muchas gracias y sigue actualizando!

    Daspor ~

  2. Eibriel
    octubre 22, 2007 en 5:07 am

    Muchas gracias por la información!!

    Espero que pase pronto el sufrimiento para los 64bitnianos…

    Saludos!!!

  3. octubre 23, 2007 en 12:03 pm

    Daspor: gracias por los elogios, 🙂 . Pues sí, zattoo se instala de forma muy similar. Estoy en ello y pronto lo veréis en pantallazos en este blog…

  4. octubre 23, 2007 en 9:19 pm

    Postdata: Lo de zattoo va a llevar más tiempo del que creía… si teníais previamente instalada una versión de zattoo 2.x y actualizáis a la 3.0.5 actual no habrá problema: funcionará (el proceso es el mismo: dpkg, apt-get de las dependencias, dpkg de nuevo, getlibs /usr/bin/zattoo_player…).
    Pero si instaláis la 3.0.5 desde cero no acaba de arrancar (problemas con el plugin de flash: la nueva versión de zattoo no se entiende con el ndispluginwrapper). Acabo de escribir un mail a la gente de zattoo con todos los datos, a ver si me dan una solución y lo cuento… 😉

  5. ragebits
    octubre 24, 2007 en 11:26 pm

    gracias por la info, un tuto completo,
    ((_8-(|)

  6. Daspor
    octubre 29, 2007 en 6:36 pm

    Ya he instalado last.fm con el mismo procedimiento.. Este tutorial va de lujo 😛

    Daspor ~

  7. robert
    noviembre 5, 2007 en 2:13 am

    muy bueno tutorial me. funciona sin problemas

    muchas gracias

    R.

  8. noviembre 5, 2007 en 4:39 am

    realmente que bueno que hay gente que se toma el tiempo necesario para explicar el procedimiento de manera concreta y sencilla para que todos podamos entender y hacer uso de ello.

    gracias

  9. esteban
    noviembre 13, 2007 en 12:59 am

    Muy buena la explicación de como instalar el skype y seguro me ponga hacerlo, pero aprovechar ya que tenes el mismo sistema operativo que instale recientemente en mi máquina, y que dicho sea de paso funciona tremendamente bien.
    Tengo una placa de Inalambrica y no logro conectarla, es decir, como tengo una lapto wireless la PC le provee internet por medio de esta placa inalambrica se conecta punto a punto, pero como te decía antes no puedo conectarla, si tenes alguna sugerencia te lo voy a agradecer mucho.
    Otra parte tengo instalada un placa capturadora de TV marca Kozumi qu tampoco logro configurar para poder ver la TV le instale una capturador que viene por defecto pero no funciono, si tenes alguna sugerencia también sera bien venida.
    La verdad que constructivo tu blog un saludo desde Buenos Aires – Argentina – Esteban

  10. alvarolivares
    noviembre 15, 2007 en 9:29 pm

    Super buen artículo y como te dijeron mas arriba, te has ganado un seguidor del blog 😀
    Yo tengo skype funcionando en gutsy, forzé la instalación pero no tengo las alarmas… veré si con tu tutorial se soluciona.
    Saludos

  11. HAJ
    noviembre 22, 2007 en 3:57 am

    Muchas Gracias!

  12. Carlos
    diciembre 9, 2007 en 3:07 pm

    Me fué de perilla para terminarlo. Ahora chuta pero tengo un problema con el video: de entre la webcam (/dev/video0) y la tarjeta de TV (/dev/video1) inicialmente sólo veía la segunda y ahora no detecta ninguna. No he encontrado ningún fichero dónde peuda configurarla a mano con lo que reinstalaré a ver.
    La pregunta va por si alguien se ha encontrado con el problema y lo ha resuelto.

  13. eva
    diciembre 10, 2007 en 8:50 pm

    Muy buen post, lo acabo de seguir punto por punto (el resumen del principio 😉 y Skype me arranca bien. Lo que no me va es el micrófono del portátil, pero eso no tiene nada que ver con estas instrucciones.

    Gracias por la ayuda y saludines 🙂

  14. diciembre 25, 2007 en 10:34 pm

    Muy buen post!
    Me funciona excelente!

    Gracias!

  15. elekpc
    diciembre 27, 2007 en 7:37 am

    hola. despues de probar las recetas, he instalado las librerias forzada, y me ha quedado con este mensaje.
    Fallo de segmentación (core dumped).
    ubuntu 64bits.

  16. ulaluna
    diciembre 28, 2007 en 1:51 am

    Me encanta tu blog es las explicaciones son mucho mejores que las de incluso el foro de ubuntu sigue asi 🙂

  17. Chaos
    enero 28, 2008 en 2:24 pm

    Gracias tio!!! Me has salvado el culo, necesitaba ponerme en contacto urgentemente por skype, y el otro ordenador con windows se ha jodido (q raro, no)

  18. enero 29, 2008 en 6:34 pm
  19. Excramasax
    marzo 23, 2008 en 6:21 pm

    Hola, escribía para darte las gracias, y de paso para reportar que a la fecha, en mi HP Pavilion dv6000, el video TAMBIÉN funciona a las mil maravillas!!!

  20. brillantejcoh
    abril 17, 2008 en 6:01 am

    no pude correlo, me salio esto
    Continue [Y/n]? Y
    Downloading …
    Failed to download file http://pe.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-core_4.3.2-0ubuntu3.2_i386.deb
    The mirrors do not have the requested file or there is no internet connection
    Failed to download file http://pe.archive.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-gui_4.3.2-0ubuntu3.2_i386.deb
    The mirrors do not have the requested file or there is no internet connection
    Failed to download file http://pe.archive.ubuntu.com/ubuntu/pool/main/libx/libxss/libxss1_1.1.2-1_i386.deb
    The mirrors do not have the requested file or there is no internet connection
    No packages to install

    seran los repos ?

  21. abril 24, 2008 en 11:18 am

    brillantejcoh: sí, eran los repos; He podido ver hoy que esos archivos descargan perfectamente, así que si lo vuelves a intentar irán bien.

    Si esto te ocurre con frecuencia, te recomiendo que cambies de mirrors; en el blog Entre Tuxes y Pepinos se publica un excelente truco para escoger el mejor servidor, estés donde estés.

  22. Aglak
    junio 1, 2008 en 11:50 am

    Muchas gracias, estaba empezando a perder la esperanza de utilizar skype con AMD64. Salud y suerte.

  23. junio 17, 2008 en 2:31 am

    hey ya que eres un genio no sabes como mepuedo conectar a internet con mi lapto hp pavilion dv6000 ya que tiene su wireless please a need conectarme a internet i need your help

  24. junio 19, 2008 en 6:19 am

    Somehow i missed the point. Probably lost in translation 🙂 Anyway … nice blog to visit.

    cheers, Charybdis.

  25. Smeagle
    julio 15, 2008 en 8:49 pm

    Excelente tutorial!!! anda muy bien. Te ganaste otro seguidor!!.
    Saludos

    adrian desde argentina

  26. Sergio de Argentina
    octubre 15, 2008 en 8:13 pm

    Hola Muchas el tutorial anduvo de 10 y lo estoy usando muchas Gracias.

  27. Marcelo
    octubre 20, 2008 en 6:21 pm

    Yo me bajé el Static de http://www.skype.com/go/getskype-linux-static y me funcionó perfecto sin hacer tanto lío.

  28. DAniel
    diciembre 13, 2008 en 3:47 am

    gracias men!!!

    me sirvio mucho tu tutorial!!!

    aunque algunas cosas ya estaban hechas en mi
    ubuntu 8.04

    XD

    vale!!!

  29. diciembre 29, 2008 en 9:09 pm

    Mira lo que me aparece…

    animano@animano-desktop:~/Desktop$ sudo getlibs /usr/bin/skype
    ./skype: /var/chroot/warty-i386/lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.7′ not found (required by /usr/lib32/libasound.so.2)
    ./skype: /var/chroot/warty-i386/lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4′ not found (required by /usr/lib32/libasound.so.2)
    ./skype: /var/chroot/warty-i386/lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.3.4′ not found (required by /usr/lib32/libasound.so.2)
    ./skype: /var/chroot/warty-i386/lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.3.4′ not found (required by /usr/lib32/libXv.so.1)

    ya no se que hacer, antes me andaba…

  30. Andrè
    marzo 21, 2009 en 7:33 am

    Simplemente perfecto. Gran solucion compañero

  31. Oscar Oviedo
    mayo 5, 2009 en 1:48 am

    Muchas Gracias, buena solución. Lo instale en un ubuntu 9.04 y no hay problemas. Sin embargo me asalta una duda. ¿Esta solución se podra aplicar a otro software con incompatibilidad con arquitectura amd64?

    Gracias nuevamente amigo.

  1. noviembre 4, 2007 en 1:03 am
  2. noviembre 14, 2007 en 11:35 am
  3. diciembre 30, 2007 en 7:21 pm

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: